Amazon Anet ET4 (has bed sensor)

Anet 3D printers, add-ons and OEM
Community rules
1. Be kind and courteous
We're all in this together to create a welcoming environment. Let's treat everyone with respect. Healthy debates are natural, but kindness is required.

2. No hate speech or bullying
Make sure everyone feels safe. Bullying of any kind isn't allowed, and degrading comments about things such as race, religion, culture, sexual orientation, gender or identity will not be tolerated.

3. Only 3D printers advertised.
Only 3D printers or directly related product may be advertised. If you post anything else it will be moderated and you will be banned.

4. Replying to posts
If you reply to a post, make sure your reply is connected with the main topic, do NOT take a topic off track.

5. All post are moderated
Every post on here is moderated - always. Don't bother joining unless you have works to share or problems to inquiry about 3D printers. That is all that will be allowed on this group.
Post Reply
User avatar
skippytheet4anet
Posts: 1
Joined: 2020-12-27 6:39

I recently bought from USA Amazon a Anet ET4. It has a bed sensor.

I have it running and its printing good in my opinion.

Few issues I have is that its extremely noisy - I thought this was a 32bit board and would be more silent but its not.

The other issue that goes along with the noise is that when the printer is doing infill at 40mm/s it sounds like its going to fall apart. Literally it sounds as if there is something loose in the X axis but everything is snug, belts, eccentric nuts, etc. When its off and if the axis is moved by hand I cannot reproduce the noise or find anything that is loose.

Here is a YT video of it... right at 5 seconds that noise you hear is what I am talking about.



The other thing I notice when compared to another printer machine I have from another company is this machine does not do auto bed level at the start of every print.

Not sure why that is, I understand it may have to do with the start gcode script but I thought that was the entire purpose of the sensor..... why auto level only once and never again?

Also, do these machines have various firmwares that can be updated or rolled back too?


User avatar
LoniNix
Posts: 1
Joined: 2021-01-02 9:49

Ok, I've had this Anet ET4X for 2 days now, just a disclaimer.

Mine is making a similar noise, a 'thumping' during print.

Looks like it's the ridges on the filament 'pusher' grinding on the filament. I would guess that the filament is being pushed too hard (too much, head fills up and blocks further 'push-in' of filament). Perhaps finding the setting for filament push speed would help.

Well, less filament, or a bigger nozzle.... I'm not crazy about printing with spaghetti noodles, so the nozzle size will remain teeny tiny (0.4mm in this instance). Heh! Angel Hair Spaghetti Prints. Hmmm.... Hot water nozzle? Insta-Boil Technology! Please insert Spaghetti Cartridge to continue!

**SO FAR** it hasn't hurt anything, everything prints well. It's just a bit concerting. Seems to calm down as the print progresses, maybe it's extruding too much at the beginning of the print? Dunno, will continue to monitor.

I *have* had some issues with filament jamming the nozzle, but I think those are related to bed levelling and nozzle height. BLTouch upgrade on order, might help.

From my own searches, ANet seems to have abysmal (ie, terrible!) support for new firmware. Nowadays, we want to put it on sd card and upgrade... not dig out the jtag interface and install all sorts of crap. Yes, I'm an engineer and know HOW to do that, but I shouldn't have to unless I'm doing something esoteric.

Other options are available, people are creating their own 'Marlin' binaries to upload, just have to figure out which are reliable and proper to reduce bricking. Additionally, the main Anet3d.com website is down (of course!). have seen many complaints of non-responses to queries directed at Anet. Perhaps the company sucks. Dunno. Don't care. But the hardware is solid, and firmware has been developed to improve it. Just need to sand off or paint over the Anet logos, right?

[rant] As a note... I find firmware for the ET4... is that for the ET4 only? or the ET4 range? (ET4, ET4+, ET4Pro, ET4X...?) Please be MUCH more specific. Do I have an ET4 with 'X' option? or an ET4X model? I mean, do I have an ET4-X, or an ET4X? To me, those are vastly different models. Like getting a Toyota Supra or a Toyota Camry... Both are Toyota's (ET4), but they're very different (ET4X, ET4-X). And no-one seems able to really identify the difference between the models (ET4, ET4+, ET4Pro, ET4X) Does one have a sunroof or something they're using to discriminate between them? (Yeah, I'd check the Anet3d.com website... but.... y'know... it's DOWN! [/rant]

This is my second 3d printer, and my first Anet. Not impressed with their firmware (v1.0.1 or something, really?!?) Web Searches are all over the place with praise and complaints. Seems no one is available. {Shrug} Whatever. I found firmware to match the motherboard, will look into that to improve the machine. Again, the *hardware* is sound. Firmware can always be fixed.
Post Reply